OPNsense Update 22.1.7

opnsense-update-22-1-7
The latest OPNsense update fixes vulnerabilities in OpenSSL, among others, and paves the way towards Phalcon 5 frameworks and PHP 8.0.

The latest update includes minor improvements and security updates:

The main ones would be:

  • OpenSSL fixes
  • Preparations for Phalcon 5 and PHP 8
  • pkg 1.17 update (change from txz to pkg)
  • New automation for ACME/Lets Ecrypt to execute commands via SSH
  • Anoymous Relay support for the DNSCrypt proxy plugin
  • CARP demotion (in HA mode) for OSPFv3 in FRR plugin
  • Zabbix proxy and agent for version 6.0

 

We will be pleased to help you if you need assistance with upgrading or setting up the new features. 

You can find more information on our OPNsense page.

Share post on

About the author

Clemens Dietl
CEO and IT services expert
clemens.dietl@max-it.de